Back to overview
Downtime
Cloudflare network downtime
Nov 18 at 12:55pm CET
Affected services
2manydots.nl
2MD Update server
client.2manydots.nl
Resolved
Nov 18 at 05:09pm CET
This incident has been resolved by Cloudflare.
Affected services
Created
Nov 18 at 12:55pm CET
Cloudflare is experiencing an internal service degradation. Some services may be intermittently impacted. We are focused on restoring service. We will update as we are able to remediate.
Affected services