Back to overview
Downtime
Some websites temporarily not available
Jul 11 at 05:08pm CEST
Affected services
2manydots.nl
Resolved
Jul 11 at 05:15pm CEST
The issue has been resolved.
Affected services
2manydots.nl
Created
Jul 11 at 05:08pm CEST
We are investigating the issue and are doing our best to resolve it.
Affected services
2manydots.nl