Back to overview
Downtime

Servers temporarily not available

Jul 10 at 02:52pm CEST
Affected services
2manydots.nl

Resolved
Jul 10 at 03:00pm CEST

The issue has been resolved and all affected websites are back online.

Created
Jul 10 at 02:52pm CEST

We are investigating the issue and are doing our best to resolve it.